HelpMyUnite appWill the MyUnite app work on my phone, tablet or other device?
¿

Will the MyUnite app work on my phone, tablet or other device?

The MyUnite app supports Apple iOS devices with iOS version 9 onwards and Android devices with Android 9 or later installed. You will also need to be using MyUnite version 2.0.0 or above. Make sure you're version of the app is up-to-date in the App Store (iOS) or Google Play store.

Was this helpful? Yes / No